Bug in search?

Discussion in 'General' started by wsbones, May 19, 2018.

  1. wsbones

    wsbones Beta Tester

    When I have the option in Bible Panel/Additional options set to Remove hyphenation

    upload_2018-5-19_12-2-45.png

    An exact search for a phrase like "inhabitants of Jabeshgilead" does not work.

    upload_2018-5-19_12-6-16.png

    It also doesn't work if I specify exact phrase rather than using quotes.
     
  2. wsbones

    wsbones Beta Tester

    Also wildcard searches do not find all the occurrences for Jabesh* when hyphenation is turned off.
     
  3. marty

    marty Beta Tester

    I tried the search after changing my settings to remove the optional hyphen and it would find "Jabeshgilead" but the word wasn't highlighted in the verse list. It wouldn't find "inhabitants of Jabeshgilead" but did find Jabeshgilead with a search for "Jabesh*" (still no highlights).
     
    wsbones likes this.
  4. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    I have confirmed that this is a bug with the "Remove optional hyphenation of compound names" setting. Thank you for the report.
     
    wsbones likes this.
  5. wsbones

    wsbones Beta Tester

    I think I found another small bug. It seems like you can't reuse a module shortcut after you delete it.

    I renamed a user module from FAVORITE to FAV. I had a module shortcut set up to open the module, FAVORITE (alt-q). After renaming, the shortcut no longer worked so I deleted it and set it up again using the same shortcut (alt-q). Everything looked right but the shortcut did not work. I repeated the whole process, but it didn't work. It said the user module FAVORITE was not found even though the shortcut dialog said that alt-q was a good key combination.

    I created a new module shortcut alt-z and that worked to open FAV.

    Then I deleted alt-z and tried to reuse alt-q. It still did not work.

    Then I tried to assign alt-z to to TSK. That did not work.