Strange issue with "verse guide"

Discussion in 'General' started by Mobi, Sep 15, 2017.

  1. Mobi

    Mobi Active Member

    When I am using the "verse guide" and I open a heading with the arrow on the side, then click on the item. It takes me to the book I selected normally.
    arrowVG.JPG

    BUT when I go back to the verse guide and click on another arrow, just clicking the arrow... takes me back to the first item/book I selected the first time automatically, and doesn't let me select a new book first so I can go to the next resource. (clicking any arrow open or closed always takes me to this page pictured)
    book open.JPG

    I have to go back to the verse guide (because I was auto directed away) with the now opened heading and select or view the resources I wanted to look through.

    Is there a setting that I have checked or unchecked that causes this behavior?
    Thank you!

    OS stats... Windows 10 Home Version 1703
    SwordSearcher Version... 8.1.1.42 (x64) Deluxe Library Version 8.1
     
    Last edited: Sep 15, 2017
  2. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    I can't duplicate the behavior I think you are describing. Can you should me a screen shot of how your whole SwordSearcher window is laid out, both before and after you click the verse guide link?
     
  3. Mobi

    Mobi Active Member

  4. wsbones

    wsbones Beta Tester

    I tried the same steps. Nothing unusual happens when I click on Naves in the verse guide. The topics under Naves expands but nothing else happens.
     
  5. Mobi

    Mobi Active Member

    Thanks Bill,
    I guess I should say that it happens (to me) with any arrow I click on and is not isolated to Naves, they all do it to me.

    I guess I should also say that it isn't with just these books I showed either. It happens (to me) with any of them. I was just trying to show the "steps". I wonder if it has to do with the way I have it set up or maybe my computer...? I have a 2 in 1 laptop/tablet set up in tent mode so that screen image is flipped in orientation to a regular laptop. Then I have a 2nd HD monitor hooked up via HDMI. I wonder if something strange is happening there?
     
    Last edited: Sep 15, 2017
  6. Mobi

    Mobi Active Member

    So I unhooked my other monitor, and I set my laptop in normal mode, and still have the issue... no change. Then I tried different layouts and get the issue sometimes but not all the time. I have one or more layouts that crash SS when I select them... both the ones that have "Bible on left". I might have a corrupted install or perhaps the download got corrupted on my old machine along with the several HDDs that also died? I'll try to reinstall and see what happens.

    EDIT...
    I tried reinstalling over the top of the already installed SS with the download I had, and received the same issue. So I downloaded the upgrade from SS site and did the same thing, and get the same result, no change. I guess I'll wait for any further suggestions before trying anything else. (except I'm gonna try it from my old machine and see if it does it too? then try again using the settings I'll save and transport from this machine to it if it doesn't)
     
    Last edited: Sep 15, 2017
  7. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    Thanks for trying those steps. My first thought was that maybe there was a layout issue, which is was I was looking for in the screen shots. I tried some configurations and can't reproduce a problem.

    However, the crash you reported does indicate some bad layout data on your system. Reinstalling doesn't erase settings so that's why you saw no change.

    Try this -- go to the File menu and choose "exit without saving layout." That should clear the layout engine and not save it on exit. Start SwordSearcher again and see if things work normally, without selecting any of your saved layouts. If it works fine, it could just be a corruption in the layout data for one of your saved layouts. You might need to reconfigure your layouts and save them again.
     
  8. wsbones

    wsbones Beta Tester

    What actually happens in your example when you click the Naves heading when you are viewing the Figures of Speech topic? What does auto directed away mean?

    You will probably have to email Brandon with your settings file created with File/Save settings.
    (Sorry, I just saw Brandon's post after I posted my response.)
     
  9. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    Mobi,
    I am sorry you're experiencing these problems. Try this. Switch to the "Classic" layout and see if that can happen without crashing, and then choose Exit Without Saving Layout. That way it won't try to load up a user-layout the next time you open it.
     
  10. Mobi

    Mobi Active Member

    I did try this, and when I restarted, the same layout I had when I exited came up which was my "custom layout" which you can see in my screen shots. The issue persists :( ... I did check my old machine and it also has this same issue, so I must have transported the issue to my new machine from the old in a corrupted setting or something.
     
  11. Mobi

    Mobi Active Member

    Okay so I got the crash again when I switched to "Classic". Then I tried deleting my custom layout, and disabled the option to "enable custom layout". I get a crash now when I select any layout option other than "single pane view". I did try to exit without saving layout, and still get crashes trying to switch layouts...

    BUT I still have the original issue of... When I click the arrow the commentary pane or book pane view (whatever was chosen previously from the Verse Guide), it continues to bring up the previous selection. So if I selected something from Adam Clarke's commentary first then... every time I click an arrow, no matter what arrow that is; I get the same Adam Clarke's commentary that I originally selected... automatically (SETS THE FOCUS back to the first commentary) . It eventually stops doing that once I click on a few sub headings, but it is random.
     
  12. Mobi

    Mobi Active Member

    So I searched my computer for *.sssettings and deleted them all, then started SS again... issue persists. I eventually got the layout "classic" to work and then "exit without saving layout" but the issue persists... I tried restarting unloading other programs, so that only SS is running... issue persists. I do have my SS user files on OneDrive and deleted the sssettings file from that making sure the sync was finished, I have highlight and markup set to save on OneDrive if that might be an issue. I dunno. I will have to try other options later I guess.
     
  13. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    The .sssettings files are backups or saved settings files you might have done from the file menu. The actual settings SwordSearcher uses are stored in the registry.

    If you can get past startup, please open SwordSearcher and then go to the Files menu and select Save Settings. Save all of the settings options to a settings file and email that to me at bstaggs@swordsearcher.com -- it may help me recreate the problem.

    At this point I would suggest wiping the SwordSearcher settings from your user branch in the registry to force SwordSearcher to start as new. The fact that you are having this happen on another machine that you copied settings to indicates to me that there is indeed a corruption in the stored layout data.

    First, you can clear the last session layout files from your computer by opening File Explorer and typing

    %APPDATA%\SwordSearcher

    in the address bar. That will take you to the place where SwordSearcher saves some things to disk. The file you want to remove is "LastLayout6" if it is there. Don't bother with the "Settings Backups" folder because those are just backups made by SwordSearcher and it doesn't load those unless you tell it to. The "LastLayout6" is just where SwordSearcher saves a copy of the last session layout to restore when it starts. If you start SwordSearcher again after deleting this, it will go to the registry and find the last layout it thinks you were using and re-create it. So, every time you start SwordSearcher, this file is re-created on exit. Delete this file and then do the following, which is really what is most important:

    If you want to try the following, please take extreme caution and do so at your own risk.

    Close SwordSearcher if it is running.

    You can edit the registry to remove SwordSearcher settings but if you make a mistake you can damage your WIndows installation or cause other problems. That being said, you can open RegEdit by clicking the start button, type "run" and enter, and then type "regedit" in the run box. It will open after a warning.

    Find your user branch SwordSearcher settings. They should be under

    HKEY_CURRENT_USER\Software\SwordSearcher

    I would highly recommend right-clicking the SwordSearcher node and selecting "Export" to save it to disk.

    First you could try specifically removing the layout sections of the settings. Those are stored in

    HKEY_CURRENT_USER\Software\SwordSearcher\CustomLayout
    HKEY_CURRENT_USER\Software\SwordSearcher\Layout

    Right-click the "CustomLayout" node and delete. Do the same for the "Layout" node.

    Try SwordSearcher one more time. If it the problem persists, close it, then go back to Regedit and then type F5 to refresh the tree. Now right-click HKEY_CURRENT_USER\Software\SwordSearcher and select Delete. You are just wanting to right-click the "SwordSearcher" node under "Software" to delete that one.

    This will completely remove all program settings from your computer for SwordSearcher, except for your serial number which is added to a different part of the registry by the installer.

    DO NOT ACCIDENTALLY REMOVE SOMETHING ELSE.

    If you give that a try and it doesn't work, or you just don't want to try it, in a week or two I could try sending you a special debug build to try to get to the bottom of the crash.

    At this point you don't need to submit any more crash reports through the crash report system -- they are all the same so there is no new information coming from those.

    Please let me know what you decide.
     
    Last edited: Sep 16, 2017
  14. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    By the way, I think you may have mentioned some kind of "portable apps" thing (maybe in one of your crash reports). Definitely do not use that when trying to work through these problems. Those kinds of programs may intercept registry calls and I would have no way of knowing where it is actually storing data or what it is doing to it.
     
  15. Mobi

    Mobi Active Member

    I tried all of the above (including registry edit), and the problem persists. I wonder if I downloaded a fresh copy of SS and reinstalled that would it help? Is there a md5 checksum or some way to verify the integrity of the copy I have?

    I figured not running anything else would be the preferred way to trouble shoot.

    Portable Apps is the solution I use to get some applications that I was used to in Linux to run in Windows.... ;) The ONLY reason I went back to Windows was to use SwordSearcher. So instead of figuring out a Bible app for Linux, I use Linux apps on Windows. https://portableapps.com LOL even with a glitch left over from my old machine; SS is still the best Bible software hands down... :)
     
  16. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    I assume when you started SwordSearcher after deleting the registry settings that all of your colors and fonts/etc were reset. If not, then something happened and we didn't find the right place for the settings.

    I'll contact you by email to continue this. I'll give a public answer here just in case someone else comes across this: The SwordSearcher executable is digitally signed, so Windows would not run it if the file itself was somehow damaged or otherwise altered on the hard drive. A single wrong bit would cause an error on startup. There could still possibly be an issue with a module file but that is pretty unlikely, and would manifest as data errors, not crashes during layout operations. If you really wanted to be sure you could uninstall SwordSearcher and re-install -- the installer does a checksum on all of the files and ensures that they are pristine. But again, if SwordSearcher is starting up, we can be sure the executable file is not damaged.

    I'll send you an email shortly.
     
  17. Mobi

    Mobi Active Member

    Oh yes the registry edit wiped out and reset everything. I tested for the issue from that state of renewal.
    My question is... are those attempting to duplicate my issue clicking the arrow itself?

    I discovered this morning...
    When you click the arrow, the issue manifests.
    When you click the words or titles or results (the words of the text not the arrow) the issue does not manifest.
    I will use this technic to work around the "issue".

    I hope I remember this the next time I ask the same question again. Sorry I forgot you told me this already. I know there are many reasons your software is so superior and this is just one more of them. (I'll go check my email now but it runs from portable apps)
     
  18. wsbones

    wsbones Beta Tester

    For me clicking just the arrow just causes the sub topics to be displayed and no other action. Clicking it again closes the sub topics.
     
  19. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    Has this resolved the crashing issue? My immediate concern was addressing the problem with the program crashing -- I had a focus on that which I don't think I communicated.
    I believe I have finally reproduced the other behavior you have reported (with clicking on the down arrow changing the commentary entry). I will look more into that right now -- I think that is a bug but I will look into it more thoroughly to see.
     
  20. Brandon Staggs

    Brandon Staggs Administrator Staff Member

    Mobi, thank you for you patience and your bug report. With regard to issue you described with the Verse Guide clicking, I have reproduced and fixed it -- the fix will be in the next program update. This is the scenario I fixed:
    • Expand the top commentary node in the Verse Guide tree and select one of the commentaries in the list.
    • In the commentary panel, change to a different commentary.
    • Now go back to the Verse Guide and click on the down-arrow for the commentary node to collapse it.
      • At this point, the commentary panel will go back to the last commentary you had chosen in the verse guide list, which is clearly not the intent. It was treating any click on the verse guide as a selection.
    I have already made the necessary fix in the code for this and again I thank you for your time and patience.
     
    marty likes this.