Default Font Size in Editor

#1
I have SS installed on a desktop (Win 7) and a laptop (Win 10). On my desktop when I open the editor to add to my personal commentary the font size defaults to "Medium" but on my laptop the drop-down showing the font size is always blank so I have to select the size I want. I suspect that there's a setting that affects this but all of the font settings I see use point sizes, not descriptive sizes shown in the editor font size drop-down where it shows "x-small" through "largest." How can I force the editor drop-down to pre-select the size I desire?

Thank you very much.
Ken Sturgeon
 

marty

Beta Tester
#2
Brandon will have the official answer, but this is what I discovered: I went to File>Preferences & Settings>Fonts & Colors, then in "Set individual panel properties," I set the font size for Commentaries to 16, and the panel automatically shows at that larger size. You may have to try different point sizes to get the size you want, but it stayed and carried over to the Editor...
 

Johnny NL

Active Member
#3
Brandon will have the official answer, but this is what I discovered: I went to File>Preferences & Settings>Fonts & Colors, then in "Set individual panel properties," I set the font size for Commentaries to 16, and the panel automatically shows at that larger size. You may have to try different point sizes to get the size you want, but it stayed and carried over to the Editor...
I also did the same thing....once you set them up individually, you will love it... it works perfectly for me too.
 

Brandon Staggs

Administrator
Staff member
#4
I have SS installed on a desktop (Win 7) and a laptop (Win 10). On my desktop when I open the editor to add to my personal commentary the font size defaults to "Medium" but on my laptop the drop-down showing the font size is always blank so I have to select the size I want. I suspect that there's a setting that affects this but all of the font settings I see use point sizes, not descriptive sizes shown in the editor font size drop-down where it shows "x-small" through "largest." How can I force the editor drop-down to pre-select the size I desire?

Thank you very much.
Ken Sturgeon
Does this happen when you open a new entry for editing, too? I mean one that hasn't ever had content. I am not sure what would cause there to be no selected font size in the drop-down... are you using the same version of SwordSearcher on both computers?
 

marty

Beta Tester
#5
I changed the Books font size in Preferences to 17, created a brand new book, brand new entry, when the Editor opened, there was no default font size in the drop-down selector. The choices are there when you click the drop-down...
 
#6
Does this happen when you open a new entry for editing, too? I mean one that hasn't ever had content. I am not sure what would cause there to be no selected font size in the drop-down... are you using the same version of SwordSearcher on both computers?
The drop down is empty only on the laptop running Win 10 regardless of whether I am starting a new entry or modifying an existing entry. The problem doesn't manifest at all on the desktop running Win 7.
 
#7
Yes sir it does update when the caret is moved within text that has already been entered. I should probably have mentioned earlier that when the editor window is first opened I can see "Medium" in the drop-down but then it disappears.
Thank you Brandon.
 

Brandon Staggs

Administrator
Staff member
#8
It's designed so that when you create a new entry, the default font size matches whatever you have set in File, Preferences, Fonts and Colors. And if you never change the font size in the entry, you can always change that setting in preferences and your user entries will display with that preference. The drop-down font size selector in the editor is there to allow you to override this setting. You should be able to just "leave it alone" if you have the font size in preferences set to a size you like.

If the preferred font size doesn't match one of the "HTML font sizes" in the drop-down list, the box will be "empty" to indicate as such. That's why that happens.
 
#9
That is exactly what the problem was. I had the default font size on one machine set to 12 but it was set to 13 on the other. I changed it to 12 and the drop-down now defaults to Medium.
Thank you very much.
:)
 
Last edited:
Top