User book file deleting?

Who can help me? I have used this program for a long time, and I know how to create a user book and always have used that option, but now all of a sudden all my saved user books that I created disappeared, and when I create a new one, I can save my content, but as soon as I exit Swordsearcher, and I open the program again, my user book is gone. It doesn't save it anymore.
 

Brandon Staggs

Administrator
Staff member
Thanks for posting this here. Someone may be able to offer an idea that didn't occur to me when we were trying to figure this out by email.

An additional bit of information -- the SwordSearcher User Modules folder on the user's computer is being emptied out by something.

Obviously SwordSearcher wouldn't delete the user modules from the folder. My best guess is that there is some kind of sandboxing going on -- some other program is erasing everything SwordSearcher does after it closes.

What anti-virus package are you using? If you are using anything other than what comes with Windows, you might try disabling it to see if there is any change.
 

marty

Beta Tester
Have you checked the recycle bin for the deleted modules? That would be my first worry - all my lost modules. If you can recover them, can you back them up to a different folder or sd card or thumb drive?

Being very careful so you don't lose files that you want... Have you tried creating a new folder and pointing SS to the new folder as your default for the user modules? Have you tried putting non-SwordSearcher files (just copies of other files, like jpg or txt files, for sure!) into the Documents/SwordSearcher User Modules folder and see if they disappear? Have you tried creating a module and before you exit SS, copy it to a different folder, exit SS, see if the module has been deleted, if it has, copy it back into the Documents/SwordSearcher User Modules folder and then open SS and see if the module is there? (That would check to see if the files are being deleted on exit or open.)

Have you reinstalled SwordSearcher? Are you losing any other files from other programs? Have you looked in the Task Manager for unknown programs that are running? Have you tried booting your computer in Safe Mode?

I can't think of anything else off the top of my head. I sure hope you get it figured out!
 

wsbones

Beta Tester
Did you get a Windows update about the time this started happening. There have been reports of lost files. Here's an example. https://www.easeus.com/data-recovery/restore-lost-documents-after-windows-10-forced-update.html
Try a search for - Windows update deleting files.

I hope you can get them back.
-----
I'm not selling software, just a backup strategy. This won't solve the current problem, but it's a good thing to do.

I use Acronis software to automatically back up every night to a separate disk drive. Once a week it backs up the whole HD including the OS. Every night it does a differential backup (anything that changed since the last full backup). It takes about 15 minutes once per week and then about 2 minutes or less per night. I also make backups to an external USB HD periodically. This has "saved" me numerous times over the years.

It's also good if you buy a new, larger HD, and need to move everything including the operating system to it.
 

wsbones

Beta Tester
If it turns out to be a windows update, you might try a free piece of software called Windows Update Stop. Window Home edition will automatically update and can cause problems. I want to pick when an update installs and I'm sure it's solid. The software allows you to turn on and turn off updates.

Here's a link - https://www.novirusthanks.org/products/win-update-stop/
 
Fixed the problem. Found out that my Module file location settings for some reason had been messed up. Still not sure how that happened, but since I had SS on a different computer, I started going thru all my settings to see what was different, and so I found the problem. Thanks guys for all your input and trying to help me find the problem.
 
Top